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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and Disconnect Properly. Do not connect or disconnect probes or test leads while they are connected
to a voltage source.

Ground the Product. This product is indirectly grounded through the grounding conductor of the mainframe power cord.
To avoid electric shock, the grounding conductor must be connected to earth ground. Before making connections to the input
or output terminals of the product, ensure that the product is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult
the product manual for further ratings information before making connections to the product.

Power Disconnect. The power cord disconnects the product from the power source. Do not block the power cord; it
must remain accessible to the user at all times.

Do Not Operate Without Covers. Do not operate this product with covers or panels removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components when power is present.
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General Safety Summary

Terms in this Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.
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Preface

Preface
The RFXpress RFX100 is a software product that allows you to create digitally modulated baseband, IF, and RF signals that
can be generated through arbitrary waveform generators (AWG). This software runs as an integral part of AWG5000 and
AWG7000 series arbitrary waveform generators and can also run from an external PC.

You can use RFXpress to:

Design, debug, and develop wideband wireless communications receivers

Generate UWB-WiMedia compliant and custom signals

Generate general purpose digitally modulated IQ, IF, and RF signals

Key Features
Define baseband I and Q signals using various modulation schemes

Create single and multi-carrier signals where each carrier is independently defined

Apply impairments such as quadrature error and imbalance or non-linear impairments

Add interferences during waveform creation

Remotely connect to Tektronix oscilloscopes and to an Agilent Performance Signal Generator

Remotely configure a Tektronix oscilloscope and an Agilent Performance Signal Generator

UWB-WiMedia
Direct RF generation of WiMedia BG1 and BG2 waveforms

Ability to generate IQ and IF waveforms including band hopping for all band groups

User-defined IF frequency including TFC pattern

Comprehensive WiMedia signal generation support for MAC and PHY layers

Ability to UWB-WiMedia correction files which can be automatically applied as compensation to accurately generate
signals

Ability to use Gated Noise to define noise profiles for each section of the UWB packet

Create tone nulling with intermediate values (20 dB to –100 dB) for OFDM carriers mapping

Documentation

RFXpress RFX100 Online Help, English Tektronix part number 076-0081-XX
RFXpress RFX100 User Manual, English, (PDF) Tektronix part number 077-0045-XX
RFXpress RFX100 Quick Start User Manual, English (PDF) Tektronix part number 071-2167-XX
RFXpress RFX100 Installation Manual, English Tektronix part number 071-2166-XX
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Conventions Used in This Manual
When steps require a sequence of selections using the software interface, the ">" delimiter marks each transition between a
menu and an option. For example, File > Save.

The document MultiBand OFDM Physical Layer Specification version 1.2 by WiMedia Alliance is referred to as the “WiMedia
standard” or “WiMedia specification”.

The term “DUT” refers to a device under test.

The terms “signal” and “waveform” are used interchangeably in this manual.
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Installation

Installation
For information on how to install this software, refer to the RFXpress Installation Manual, Tektronix part number 071-2166-00.

Starting the Software
Start the software in either of the following ways:

From Start > Program Files > Tektronix RFXpress, click RFXpress.

Double-click the RFXpress icon on your desktop.

Closing the Software
Click File > Exit to close the software.

Software Upgrades
Periodic software upgrades may become available. The software is operational only if you have a valid option key for the
specific instrument model and serial number.

To check for upgrades:

1. Go to www.tektronix.com/software.

2. Enter the product name (RFXpress).

RFXpress RFX100 Quick Start User Manual 1
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Using the Software

Using the Software
This section covers the following information:

Getting acquainted with the software

Generating a signal

Adding impairments to the signal

Compiling a signal

Graphing a signal

Getting Acquainted with the Software
Using the Software Interface
Use the keyboard or mouse to make selections in the software.

Use menus, toolbars, check boxes, and on-screen buttons to control the software functions. Use Microsoft Windows
techniques to navigate menus and select or clear check boxes.

Generating a Single Carrier Signal
This section shows you a step-by-step procedure for creating a single carrier QPSK baseband signal.

1. Start RFXpress.

2. From the toolbar, click Select > Generic
Signal.
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Using the Software

3. Set the signal type to IQ.

4. Click Carriers > Single Carrier.

5. Select the carrier and set the following:

Baseband Offset to 0 Hz

Amplitude to 1 Vrms

6. Ensure that the following parameters are
set:

Modulation is QPSK

Filter is Raised Cosine

Symbol rate is 1 MHz

Alpha/B*T is 0.35

Window is None

Compiling a Signal
Follow these steps to compile and generate a signal using the parameters that you just defined.

1. From the toolbar, click Compile.

2. The compiled waveform is displayed in
the waveform list.

NOTE. If the waveform list is not visible, click Window > Waveform List to view it.
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Generating a Multi-Carrier RF Signal

1. From the toolbar, click Select > Generic
Signal.

2. Select the signal type as IF/RF.

3. Select Multi Carrier.

4. You can either add carriers directly or
delete the existing carrier and add new
ones. Select the carrier in the table and
click Delete.

5. Click Add Carriers and type 3.

6. Click Range. Set the Base Frequency
to 10 M and the Carrier Spacing to
10 M.

7. Click Add.

8. Select the first carrier from the table.
In the Setup tab, set the Base Data to
PRBS and select 15 from the adjacent
field.

9. Set the Modulation for the carrier to
QPSK.

10. Repeat steps 4 and 5 for the remaining
carriers, setting the Base Data to
PRBS 21 and PRBS 7, and Modulation
to QPSK.
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Adding Power Ramping, I/Q Impairments and Interference

1. Select the first carrier from
the table. Select the Power
Ramping tab.

2. Select Turn On.

3. Set the Ramp parameters:

Function to Linear

Time to 100 nsec

4. Set the Position parameters:

Symbol to 0

Level to 0.00

5. Click Add.

6. Repeat steps 4 and 5 two more
times, adding these parameters:

Symbol = 100

Level = –80 dB
and

Symbol = 200

Level = 0 dB
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Using the Software

7. Select the second carrier
from the table. Select the I/Q
Impairments tab.

8. In the Carrier Leakage group,
select Turn On. Set the following
parameters:

I to 5.0

Q to 5.0

9. Select the third carrier from the
table. Select the Interference
Addition tab.

10. In the Offset group, select Turn
On. Set the Frequency to 10 M.

RFXpress RFX100 Quick Start User Manual 7
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Compile Settings and Compile

1. From the toolbar, click Compile >
Compile Settings.

2. Set the Waveform Length to 500K and
the units to samples.

3. Set the Oversampling to 6.00.

4. Click OK.

5. From the toolbar, click Compile. The
compiled waveform is displayed in the
waveform list.
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Previewing Graphs

1. From the toolbar, click Graph.

2. In Graph Setup, select the folder and
click Add to add the following graphs.

Frequency Domain: Spectrum

I Vs Q: Constellation

Statistical: CCDF

3. The graphs are added to the Selected
Graphs.

4. Click OK.

5. Click Graph Preview at the lower left of
the screen to view the graphs.
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Application Examples

Creating a UWB Waveform to Test Your Receivers
You can create an ideal waveform and use it to test whether your receivers are operating within the WiMedia specifications.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. By default, Conformance is selected.

4. From the Select Setup, select WiMedia
Spec Example Packet.

5. The WiMedia Spec Example Packet
settings (according to Annex A of the
WiMedia specification document) are
displayed in the fields in each tab.

6. Confirm the Hopping Pattern for TF
Code 1.

7. Click Compile.
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8. Add the following graphs in Graph Setup:

Frequency Domain: Spectrum

I Vs Q: Constellation

Time Domain: I & Q

9. Click OK.

10. The graphs are as shown.
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Characterize Receiver Design for Receiver Verification and Stress Test
You can generate a signal and use it to test your receiver at conditions just outside the boundary values specified by the
WiMedia standard.

1. Start RFXpress.

2. From the toolbar, click Select >
UWB-WiMedia.

3. Set the signal type to IF/RF.

4. Click Custom.

5. From the Select Setup, select WiMedia
Spec Example Packet.

6. The default values for the selected setup
and packet are shown graphically.

7. For the selected packet group, set TF
Code to User Defined.

8. To define a hopping pattern: In each
column, click the frequency that you
want to use. Set the hopping pattern to:
323323.

9. Assign a TFC number for the pattern that
you defined and click OK.
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Adding Interference

1. Click Interference Addition.

2. In the Gated Noise group, select Turn
On.

3. Click Packets.

4. Click PLCP Header and set it to –10.0.

5. From the standard toolbar, click
Compile.

6. In the Waveform List, select the IF/RF
waveform and right-click. Select Show
Graph > Time Domain.

7. Observe the noise in the header. The
noise of 10 dB is greater than the signal.
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Replay a Captured Waveform to Test Receivers
You can capture a real world signal in a real-time spectrum analyzer and play it back in multiple locations to test your DUTs.

Import an RTSA File

1. Start RFXpress.

2. Ensure that the selected application is
set to Generic Signal and the signal
type is IF/RF.

3. From the menu, click File > Import from
File.

4. Select the file type as iqt.

5. Select an iqt file.

6. Click Open.

RFXpress RFX100 Quick Start User Manual 15
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7. You will find two files, I<filename> and
Q<filename>, in the waveform list.

8. Set Carriers as Multi Carrier.

9. Select the existing carrier and click
Delete.

10. In Add Carriers, enter 1.

11. Select an empty row in the table.

12. In the Setup tab, set Modulation to
File1(Samples).

13. In the Modulation File(Samples) window,
click Internal.

14. Click the waveform list icon.
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15. Select the I<filename> waveform and
click OK.

16. Set Data Org to I Only and click OK.

17. Set the Input File Sample Rate to the
values with which the iqt file was created.

NOTE. If you do not know the sampling rate
with which the file was created, you can find
it by looking at the sampling rate displayed
in the waveform list.
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18. Set the following:

Frequency to 1 GHz

Amplitude to 0 dBm

19. Click Add.

20. Repeat steps 10 through 19 for the
Q<filename> waveform, setting Data
Org to Q Only.

21. Click Interference Addition. In the
Sinusoidal Interference group, select
Turn On.

22. For each carrier, set the following:

C/I to 0 dB.

Offset from Carrier to –600 M.

23. From the toolbar, click Compile. The
software uses the default compile
settings to generate the waveform.
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24. Add the following graphs in Graph Setup:

Frequency Domain: Spectrum

Time Domain: I & Q

25. Click OK.

26. The Spectrum graph is as shown.
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Using Calibration to Increase the Flatness of a UWB Signal Path up to DUT
The calibration feature allows you to generate correction files that you can use during compilation to predistort the signal,
thereby increasing the flatness of the signal.

1. Set up the instruments as shown. The
instruments must be connected over a
LAN.

You will need:

A Tektronix AWG7102 with Option 06
running RFXpress software

A Tektronix TDS6154C oscilloscope
to capture the signal

Connecting cable

NOTE. Ensure that the output of the AWG
Interleave channel is connected to Channel
1 of the oscilloscope.

2. Start RFXpress.

3. From the toolbar, click Select >
UWB-WiMedia.

4. From the toolbar, click Calibration.

5. The Calibration window displays a table
of instruments connected on the network.
Select the TDS6154C oscilloscope and
click Connect. Note that the status
changes to Connected.

NOTE. You can click Test Connection to test
the status of the instrument.

6. Set the Signal Type to RF.

7. Set the Sampling Rate to 19.9584 GS/s.

8. Select Interleave.

9. Set the Average to 10.

10. Set the Band Group to 2.

11. Select the Bands: 1, 2, and 3.
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12. Set When compiling, apply correction
files to to Ch1.

13. Set the Amplitude for Ch1 to 0.5 Vpp.

14. Set the path for Select the correction
file.

15. Click Calibrate to create the correction
file (.rfc). The calibration status is
continually updated.

16. Confirm that the correction file that was
just generated is selected.

17. Set Band Group to BandGroup 2.

18. From the toolbar, click Compile >
Compile Settings.
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19. Ensure that the correction file created
during calibration is applied to Ch1.

20. Set the Waveform Length to 1 M
samples.

21. Set the Signal Format as follows:

Select IF/RF

Set Oversampling to 3.60

NOTE. Oversampling is set to 3.60 to
achieve a sampling rate of 19.9584 GS/s.

22. Click OK.

23. From the toolbar, click Compile.
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